PHPMyAdmin e versione di PHP: incompatibilità

Alcune volte capita che phpmyadmin fornisca dei warning in merito a funzioni deprecate.

Questo capita in quanto la versione di PHP utilizzata da apache non corrisponde a quella di phpmyadmin, di conseguenza ci sono due strade:

  1. Cambiare versione di PHP o aggiornare phpmyadmin
  2. Chiedere a phpmyadmin di ignorare i warnings

Per ignorare i warnings √® sufficiente immettere il seguente testo all’interno del file /etc/phpmyadmin/config.inc.php:

$cfg['SendErrorReports'] = 'never';